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Monitoring, alarm, control, automation 

This manual includes steps to install, set up and use your system. 
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Applications: 
 

 Large pharmaceutical warehouses 

 Hospitals 

 Small-scale pharmacies and laboratories 

 Small storage facilities  
 
Monitoring solutions should incorporate a complete management system 
that includes the following features: 
 

 User management; 

 Sensor inventory management; 

 Site calibration management; 

 Reading the sensors, installed at every site; 

 All sensors or tags clearly assigned to a specified location; 

 Management of alarm set points; 

 Directing alarm messages to specific individuals. 

 Rapid tracking of system activities. 
 

 

Features of the module GTalarm2 
 

 2G or 3G modem 

 4 Analog inputs (pull up 5.1K)   0-10V 

 2 Analog Input/ Output ,  0-10V , 0-20mA 

 3 Digital Inputs/Outputs  3.3V , 20mA,  

 4 PGM outputs 24V/1000mA. Open Drain. 

 Up to 32 sensors, temperature, humidity etc. 

 * Digital expansion module BUS. 

 In-field firmware upgradeable via USB and SERA2 software 

 Events log buffer. 2048 events 

 Program remote controls using the master or installer codes 

 Up to 800 users remote controls with mob phone, 

 Up to 800 users remote controls with iButton or RFID keycard 

 Up to 800 user code. To control with Wiegand keyboard. 

 Built-in-real-time clock backup battery 

 Unlimited control via SMS. 

 Push button software reset 
 
*Bus terminal can be used as digital output. There is no expansion module 

function at the moment. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The meaning of icons in the manual: 

 
  

Very important Important About the manual 
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1 Building monitoring, alarm system 

Automated data monitoring provides reliability advantages compared to manual measurements, which rely on human intervention. It could be used for 

measurement of the temperature and/or relative humidity distribution within a storage area, including identification of hot and cold spots. Temperature 

sensors should be located in areas where the greatest variability in temperature is expected to occur. Temperature, humidity sensors should be positioned 

so as to be minimally affected by transient events such as door opening. The advantage of the system: data recorded accurately and continuously. 

Automation data monitoring system has the following technical characteristics: 

Temperature 

Humidity

Analog 0-10V 

Sensors

Analog 4-20mA 

Event Log

Event Monitoring

Remote Control

Process Automation

Alarms

GTalarm2

module

 
Figure 1 The purpose of the module GTalarm2 

Continuously collect and buffer data, even during 
power loss.  
 
Various sensors:  temperature sensors for ambient 
and refrigerated stores, sensors with remote probes 
for low temperatures, temperature and relative 
humidity sensors and sensors for logging events 
such as door opening.  
 
Sensors could be calibrated manually. 
 

  

The advantages of the system: 
- It is possible to connect up to 32 sensors for monitoring purpose. 
- Low and high threshold for output activation. Cooler, heater or other device will be 

activated, before temperature goes out of range; 
- Sensor calibration. Temperature, humidity measuring will be more accurate and 

stable over the selected range after sensor calibration. 
- Celsius to Kelvin, Fahrenheit conversion. 
- Event alarms such as mains power failure or door open. Operational events (for 

example door opening in freezer rooms and cold rooms) can have a significant impact 
on environmental control. Users can react earlier and the damage could be less if they 
will be informed about unwanted events. 

- It is possible to connect to the module via Linux server. This system is user 
programmable and may also be remotely monitored and controlled via Linux server. 

- Events log. Events may to be logged and recorded. Up to 2048 events could be logged 
to the system if more events needed, events could be logged via Linux server. 

- Hysteresis. 

 
Figure 2Hysteresis visualization 

- High and low alarm hysteresis. The module will not send events if the temperature 
fluctuates in defined temperature range. 

- High and low hysteresis for output activation. The module will not activate / deactivate 
the temperature output, if the temperature fluctuates in defined temperature range 
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Figure 3Sensors connection to the module 
GTalarm2 
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1.1 General view of the module  

  

 
 

 
 
 
 
 
 
1. Micro SIM card holder of 
“Push-Push” type 
2. GSM antenna connector 
3. RESET button 
4. Mini USB programming 
connector 
5. REG (yellow) see table 3 
6. DATA (red) see table 3 
7. WDG (green) see table 3 
8. Power supply and 
input/output connector 
9. External microphone 
connector 
 
 

 

 

 
Do not locate SIM card with force, because you may damage SIM card holder 

1.2 Meaning of LEDs and contacts 

Table 1 Meaning of LEDs 

Name  Indication variations Meaning 

WDG (green) built-in 
LED 

Watchdog heart beat blinking, remains lit for 
50ms, and turns off after 1000ms. 

The module is functioning.  

Off The module is out of order or no voltage 

REG (yellow) built-in 
LED 

Lights continuously Modem has been registered to the network 

Flashes, remains lit for 50ms, turns off for 
300ms 

Modem is being registered to the GSM network. 

Blinking fast, remains lit for  50ms turns off 
for 50ms  

PIN code of SIM card error. PIN code request should be removed 

Off Modem failed to register to the network. 

DATA (red) built-in LED Lights continuously 
The memory of the module contains unsent reports to the user or to the 
server. 

1.3 First steps to prepare GTalarm2 module and Sera2 software 

Preparation procedure of the module GTalarm2.  
• Connect the GSM antenna to the antenna 
connector.  
• Insert the SIM card in the SIM card holder. 
Ensure that PIN request function is disabled.  
• Connect the module to the computer via 
mini USB cable. 

Install configuration software SERA2.  
• Go to the http://topkodas.lt/ website and download SERA2 software. 
• Open the folder containing installation of the software SERA2. Click the file 
„SERA2 setup.exe“ 
•  If installation directory of the software is OK, press [Next]. If you would like to 
install the software in the other directory press [Change], specify other installation directory 
and then press “next”. 
• Check if the correct data are entered and press Install 
• After successful installation of the software SERA2, press [Finish] 

Connection of the module to your PC 

 

The module must be powered with (+12V >500 mA) voltage, it should have inserted SIM card (with replenished account and removed PIN 
CODE REQUEST). Module must be connected to the PC via micro USB cable 

Work with the software SERA2 

 

SPK

MIC MIC

SPK

COM

Figure 4 GTalarm2 PCB Layout 
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Start the software SERA2. Go to „Start“> „All programs“> „SERA2“> „SERA2 “or go to installation directory and click „SERA2.exe“. 

If you are sure that the module is fully connected to PC and power supply, please go to Devices > GTalarm v2 

 

 

 

  

 

 

 

Each time after configuring the module press Write 5 icon thus the software SERA2 will write configuration changes into the module! 

 

After configuration of the module, all settings may be saved at PC. It enables to save time, when next time the same configuration will be used – it will not 

be necessary again to set the same parameters. If you want to save that is already recorded by the module, firstly you must read configuration of the 

module. Press Read 4 icon.  In order to save configuration go to File 1 then press “Save As” or “Save”. Enter configuration parameter in the displayed 

table and press „OK“ 

In order to start saved configuration go to File then press Open 

It allows to copy the same programmed content into as many modules as required. 

2 Power supply, Battery Wiring  

It is possible to supply the security system from stabilized power supply 
source 10-15 V and not less than 1,5A. It is necessary to calculate max 
current of power supply. The current of the alarm system is the current used 
by sensors, relays, siren and other devices. It is most convenient to use 
power supply source applied for power supply of security systems with the 
option to connect backup lead battery. It is recommended to mount remote 
control relays into sockets. Sockets may be easily fixed in metal box. It is 
necessary to select relays according to preferred voltage and current.  
Power supply application note: 
https://www.topkodas.lt/Downloads/GTalarm2_TPS12_AN_EN.pdf 
 
Power supply installation manual: 
https://www.topkodas.lt/Downloads/TPS12_UM_EN.pdf 
 
Do not reverce the polarity 
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Figure 6Power supply connection 

3 Applications. Examples. 

There is several examples of applications with temperature sensor DS18b20 and temperature, humidity sensor AM2320. The same AM2320 sensor could 

measure temperature and humidity. 

The DS18b20 digital thermometer provides 12-bit Celsius temperature measurements. The DS18b20 communicates over a 1-Wire Each DS18b20 has 

a unique 64-bit serial code, which allows multiple DS18B20s to function on the same 1-Wire bus. Thus, it is simple to use one to control many DS18b20s 

distributed over a large area. Applications that can benefit from this feature include HVAC environmental controls, temperature monitoring systems inside 

buildings, equipment, or machinery, and process monitoring and control systems. 

Temperature and humidity combined sensor AM2320. It is digital temperature and humidity sensor is a digital signal output has been calibrated. Using 

special temperature and humidity acquisition technology, ensure that the product has a very high reliability and excellent long-term stability.  Ultra-small 

size, low power consumption, signal transmission distance up to 20 meters, making all kinds of applications. Applications: HVAC, dehumidifiers, testing 

and inspection equipment, consumer goods, automation, data loggers, gas stations, home appliances, humidity control, medical, and other relevant 

humidity measurement and control.  

3.1 Single sensor control 

Input D1 on the module measures the temperature of a chamber or oven with 
a temperature sensor. Control loop takes feedback directly from the input D1 
and signals output OUT1 on the module to switch the heater that heats the 
chamber or oven accordingly. 

 The signal from the input is used as feedback to the control algorithm. 

 The signal from the output controls the heater by signaling when the 
heater should be ON for ON – OFF control or how long it should be on. 

 Enter names for inputs, outputs to make the application easier to 
understand. 

 Sensors calibration possible 

DS18b20 

temperature 

sensor

Heater

Chamber or OvenGTalarm2

D1 Out 1

 
Figure 7 Single loop control 

Figure 5 The meaning of icons 

https://www.topkodas.lt/Downloads/GTalarm2_TPS12_AN_EN.pdf
https://www.topkodas.lt/Downloads/TPS12_UM_EN.pdf
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3.2 Heat and cool control loop 

Input D1 on the module measures the temperature of a chamber with a 
temperature sensor. Control loop takes feedback directly from the input D1 
and signals output OUT1 on the module to switch the heater that heats the 
chamber and OUT2 to cool the chamber as needed. 

 The signal from the input D1 is used as feedback to the control 
algorithm. 

 The signal from the OUT1 controls the heater by signaling when the 
heater should be ON for ON – OFF control or how long it should be on. 

 The signal from OUT2 controls cooling by signaling, when the chiller 
should be ON. 

 Enter names for inputs, outputs to make the application easier to 
understand. 

 Sensors calibration is  possible 
Heater

Environmental ChamberGTalarm2

D1 Out 1

Chiller

Out 2

DS18b20 

temperature 

sensor

 
Figure 8 Heat and cool control loop 

3.3 Process Alarm 

 

Input D1 on the module GTalarm2 measures the temperature of a chamber or 
oven with a temperature sensor. GTalarm2 monitors the temperature from the 
input D1, which is also used by the control loop as feedback for heat control. 
When the temperature goes out-side the normal range defined by the user-
adjustable, alarm set points, OUT1 energizes an audible alarm and an indicator 
lamp to get the operator’s attention. 

 The signal from Input D1 is the one the GTalarm2 monitors against the 
alarm set point. 

 The signal to the output indicates when the alarm has occurred. The alarm 
message could be send to the user in case of temperature alarm whether 
or not there is an output attached 

 The output could drive external devices as shown in this example. 

 Enter names for inputs, outputs to make the application easier to 
understand. 

 Sensors calibration is  possible 

 If output activation in case of alarm events is needed, please configure 
required parameters in "Sensors/ Automation" window.  

Chamber or OvenGTalarm2

D1 Out 1 Out 2

Indicator Lamp

Alarm Buzzer

AM2320

humidity, 

temperature

sensor

 
Figure 9 Process Alarm 

If Indicator lamp and alarm buzzer is needed, please refer to the “Fire and Security system” application note. 

  



GTalarm2 Application Note: Automation   8 | E N    

3.4 Temperature, humidity control 

 

The temperature and humidity of an environmental chamber are controlled by 
two loops. Loop1 uses a heater to increase the temperature and cooling coil 
to lower the temperature. Loop2 uses a solenoid to control water to flow to an 
atomizer to raise the humidity and a dehumidification coil to lower the humidity. 
To minimize wear on the compressor and use of electricity, the compressor is 
turned OFF and ON by the controller’s output for compressor control. 

 The signals from the temperatures and humidity loops’ determine when 
the temperature, humidity loops need the compressor to be on. 

 The signal from OUT signals when to turn on the compressor. 

 To save power and extend the life of the compressor, it is desirable for 
the compressor to be off when it is not needed.  The need for the 
compressor is anticipated by monitoring the inputs. 

 Delay times could be set. 

 Enter names for inputs, outputs to make the application easier to 
understand. 

 Sensors calibration is possible. 

 Set the hysteresis parameters long enough to protect the compressor 
from too much cycling, but short enough to allow the compressor to turn 
OFF between uses. 

 

Environmental ChamberGTalarm2

D1

Out 3

Dehumidification CoilOut 4

Out 1

Out 2

Atomizer

Cooler

Heater

AM2320 humidity, 

temperature sensor

 
Figure 10 Temperature, humidity control 

3.5 Ventilation control 

 

D1 D2 D3

Out1 Out2

GTalarm2 controller

 

The kitchen ventilation requirement is based on the intensity of the use of the equipment (the cooking equipment is never all at once in the 'cooking mode') 

The module GTalarm2 was designed to be on one automatic, continuous and extremely smooth way respond to current situations without human 

intervention and to be applicable in all possible ways business scenarios in kitchens. 

- When the kitchen is not in operation, the module GTalarm2 stop the ventilation or to continue with a low capacity to maintain good hygiene during 
inactivity. The fans and control valves are automatically set to the minimum air flow settings.  

- When the unit in on operation, the module GTalarm turns on the ventilation. The control valves and fans are set to the maximum air flow settings. 
The control valves and fans could be controlled depending on temperature or humidity sensor’s values. 
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HVAC control. Switch from min to max airflow 

 

Temperature and humidity sensor. The same sensor can measure temperature and 
humidity. It is possible connect up to 3 temperature- humidity sensors to the D1, D2, D3 
inputs. 

 

The house ventilation requirement is based on the intensity of the use of the equipment. The module GTalarm2 was designed to be on one automatic, 

continuous and extremely smooth way respond to current situations without human intervention and to be applicable in all possible ways scenarios in the 

house. 

- When the kitchen is not in operation, the module GTalarm2 stop the ventilation or to continue with a low capacity to maintain good hygiene during 
inactivity. The fans and control valves are automatically set to the minimum airflow settings.  

- When the unit in on operation, the module GTalarm2 turns on the ventilation. The control valves and fans are set to the maximum airflow settings. 
- The control valves and fans could be controlled depending on temperature or humidity sensor’s values. 

3.6 Multiple sensors application. Smart house. 

 

 
 
Up to 32 sensors could be connected to the module GTalarm2.  
Up to 32 temperature sensors could be connected to the same input. 
Up to 3 temperature- humidity sensors could be connected to D1, D2, D3 inputs. 
Up to 6 outputs could be used for device control purpose. 

 
 

 

 

Multiple temperature sensors. It is possible to 
connect up to 32 temperature sensors to the 
module GTalarm2. 

  

 

Temperature- humidity sensor. The same 
sensor can measure temperature and humidity.  

  

 

PIR movement detection sensor. 

  

 
Magnetic contact. 

  

 
0-10V voltage sensor 

  

 
4-20mA current sensor. 

  

 

Heating control. It is possible to switch ON or 
OFF heating device. 

  

 

HVAC control. It is possible to switch HVAC to 
minimum or maximum air flow. 

  

 

Barrier control. It is possible control the barrier 
up or down from mobile phone. 

  

 

Garage door control. It is possible control the 
garage door up or down from mobile phone. 
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Various types of sensors could be used with the module GTalarm2. It is possible to connect to the module GTalarm2 on any web-enabled device to see 
you sensor data, set alarms, customize text alerts, etc. Types of sensors:  

 The Temperature and Humidity Sensor is used to measure atmospheric temperature and humidity in indoor environments. Useful in server and 
clean rooms, humidors, museums, industrial spaces, greenhouses, and heating and ventilation applications. 

 The Temperature (Thermistor) is used to measure temperature in freezers, HVAC units, on pipes and in liquids. 

 The Motion Detection Sensor is used to detect movement within a specific area. Motion detection sensors are frequently used in security and 
energy management applications, among others. 

 The Dry Contact Sensor is used to detect the opening of a door. Useful in warehouses, real estate, cottages, second homes. 

 The 4-20ma current sensor is used to measure the current in sensors, probes or other devices. 

 The 0-10 volt sensor is used to accurately measure charge - or voltage - for up to 10 Volts across two wires. Useful for measuring output from a 
variety of sensors, probes and devices. 

It is possible to control devices, connected to the outputs of the module GTalarm2. For example: 

 Set the HVAC system to the minimum or maximum airflow. 

 Control automatic gates. 

 Turn ON or OFF heating device.  
 

3.7 How to control heating or cooling device with the module GTalarm2 

 

3.7.1 How does smart thermostat, alarm system works? 

  

The module will keep the home at a stable temperature  
 

 
 
Figure 11 The controller will turn ON/ OFF heater, depending of the 
temperature 

 
„Min Value To Activate Output“ temperature is great for helping 
prevent  home from going below certain temperatures by turning on 
heating when the set limits are reached. Turn off the heating, when 
comfort zone is reached. 

The smartphone will alert user  if there are unusual temperature changes 
at home. 
  

 
 
Figure 12 The controller will send alarm SMS and call to the user if the 
temperature will reach alarm value 

 
„Min Value Alarm“ temperature can prevent the pipes from freezing, even if the 
heating system is broken. The module GTalarm2 will inform the user (send alarm 
SMS and call) 

 

Temperature control system relies upon a controller, which accepts a temperature sensor as input. It compares the actual temperature to the desired 

control temperature, or set point, and provides an output to a control element. An on-off controller will switch the output only when the temperature crosses 

set point. For heating control, the output is on when the temperature is below the set point, and off above set point. Since the temperature crosses the set 

point to change the output state, the process temperature will be cycling continually, going from below set point to above, and back below. 
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Figure 13 how does smart thermostat, alarm system works? 
 

 

3.7.2 How to prevent the output from frequently changes according to minute temperature changes 

 

ON/OFF control action turns the output ON or OFF based on the set point. The output frequently changes according to minute temperature changes as a 

result, and this shortens the life of the output relay or unfavorably affects some devices connected to the Temperature Controller. To prevent this from 

happening, a temperature band called hysteresis is created between the ON and OFF operations.  

In cases where this cycling occurs rapidly, and to prevent damage to contactors and valves, an on-off differential, or “hysteresis, “is added to the controller 

operations. This differential requires that the temperature exceed set point by a certain amount before the output will turn off or on again.  

 

 

Figure 14 The example of configuration. Sera2> Automation/ Sensors. Double click on the selected line. 

 

 

 
Max Value hysteresis is the same hysteresis for Output activation and for alarm event. 
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3.7.3 The example of heating, cooling control with the module GTalarm2 

 

Figure 15The explanation of hysteresis 
 

 
Figure 16 The example of sensor's setting 
 

The module activates the output at the set point. The event recovers from the hysteresis value. 
 
Temperature 28 degrees – OUT1 will be activate after 1000ms. „Max Alarm Event 
Delay“prevents from OUT1 activation in response to short-term temperature fluctuations, for 
example because of window or door opening.  
Temperature 30 degrees –alarm SMS with the text “Max Value” will be send after 10000ms 
 
If the hysteresis set to 1. The system will work as follows: 
Set point = 28 degrees 
When temperature rise to 28 degrees, turn on the cooler. When temperature drops to 27 degrees, 
the system will turn off the cooler.  

 

ON- OFF control switches the output either full ON or full OFF, depending on the input set point and hysteresis values. The hysteresis value indicates the 

amount the process value must deviate from the set point to turn on the output. With hysteresis set to 0, the process value would stay closer to the set 

point, but the output would switch ON and OFF more frequently, and may result in the output “chattering”. 

In order to control big power alternating current equipment, it is comfortable to use solid state relays.  

AC/DC adapter with the voltage 10V - 14V and current >=1A might be used to powering the module. We recommend to use TPS12 power supply with 

the deep discharge protection. The solution with GTalarm2 module will gives a call and send SMS warning when the battery voltage reaches the limit.  

https://www.topkodas.lt/Downloads/TPS12_UM_EN.pdf 

https://www.topkodas.lt/Downloads/GTalarm2_TPS12_AN_EN.pdf 
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Figure 17 the example how to control heating or cooling device with the module GTalarm2 

 

 

3.7.4 Change the room temperature remotely via mobile, web app 

Up to 32 app based thermostats in one module –allow to control a thermostat using mobile, web app. Module GTalarm2 will let control, change  the room 

temperature remotely 

 

 

 
Please refer to the “Android, web app” user manual:  https://www.topkodas.lt/Downloads/GTalarm2_App_AN_EN.pdf 
 

 

3.7.5 Change the room temperature with SMS text messages 

This application is useful when the area where the controller located is in a cellphone service, but there is no internet access. For example: the cabin in 

the mountains.  This solution will allow to send an SMS/text message to remotely turn up the thermostat, ahead of time, so that it's warm when the customer 

will arrive. 

https://www.topkodas.lt/Downloads/GTalarm2_App_AN_EN.pdf


GTalarm2 Application Note: Automation   14 | E N    

Commands can be given in two different ways: the first one is to send the SMS according to required syntax and with the password (if required), needful 

to avoid strangers to operate the configuration 

 
 
 
 

 

Multiple temperature sensors. It is possible to connect up 
to 32 temperature sensors to the module GTalarm2. 

 

Temperature- humidity sensor. The same sensor can 
measure temperature and humidity.  

 

Heating control. It is possible to switch ON or OFF heating 
device. 

 
 
 

INST000000˽070˽N#VALUE # 

Programming of  max sensors value upon reaching, the SMS message with „High Alarm“ text will be sent 
070= command code (max sensors value upon reaching which, the SMS message with „High Alarm“ text will be 
sent) 
N = sensor number 
VALUE= Format 0000.00 High Alarm Value 
 

INST000000˽071˽N#VALUE # 

Programming of  minimal sensors value upon reaching the SMS message with „Low Alarm“ text will be 
sent 
071= command code (min sensors value upon reaching which, the SMS message with „Low Alarm“ text will be 
sent) 
N = sensor number 
VALUE = Format 0000.00 Low Alarm Value 

INST000000˽072˽N#VALUE# 

Programming of sensor max value upon reaching the selected output will be activated. For example cooling 
equipment 
072= command code (sensor max value upon reaching the selected output will be activated.) 
N = sensor number 
VALUE= Format 0000.00 sensor max value upon reaching, the selected output will be activated. 

INST000000˽073˽N#VALUE# 

Programming of sensor min value upon reaching the selected output will be activated. For example heating 
equipment 
073= command code (sensor min value upon reaching the selected output will be activated.) 
N = sensor number 
VALUE= Format 0000.00 Sensor min value upon reaching which, the output will be activated. 
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4 Sensors. Inputs. 

4.1 Steps to start humidity sensors DHT22/AM2305/AM2306/AM2320/AM2321  

Module should work with following sensors: Aosong 1-Wire bus Humidity Sensor DHT22, AM2305, AM2306. Also a new smaller sensor exists AM2320 & 

AM2321. 

Table 2   Sensors AM2320/AM2321 specification 

Manufacturers' Specification 

 AM2320/AM2321 

Operating Range 0–100 

Absolute accuracy (%RH, 25°C) ±3% (10-90%);   ±5% (<10, >90%) 

Repeatability (%) ±0.1 

Long term stability (% per year) 0.5 

1/e Response (sec) 5 

Voltage supply (V) 3.1–5.5(AM2320);   2.6–5.5(AM2321) 

 

The table lists values taken from datasheets. The Aosong data sheets do not specify maximum tolerances for most parameters, just 'typical' values. It 

would therefore seem that any particular device is not guaranteed to meet these specifications. For all the other devices the numbers above are the 

maximum tolerances and most also offer better 'typical' specifications.  

Each AM2320 sensor connects on separate bus line to digital inputs (D1, D2, and D3). Total up to 3 AM2320 Aosong (Guangzhou) humidity sensors can 

be connected to GTalarm2  

 

 

 
Figure 17 AM2320 connecting diagram 

Steps to start AM2320 sensors: 
1. Connect AM2320 to D1, D2, D3 according connection diagram.  
2. Sensor’s type should be select in the System Options> Digital I/O Settings window. 
Set digital input definition D1, D2, D3 to Aosong 1 Wire bus Humidity Sensor AM2320 
3. Write configuration 
4. Power module.  
5. After module starts , read configuration 
6. Go to “Automation/ Sensors” window in the SERA2 software 
7. Double click on the selected sensor’s line.  
8. Click on “Sensor type/ hardware location” and default sensor settings appear. 
9. In sensors table column Sensor HW ID find registered sensors AM2320 looks like 
"GTalarm, Input D1, 1-Wire, AM2320 Huminidty, 28AE51560500" Location of the sensor 
can be changed choosing wanted sensor in the list 
10. Double click on the sensor row opens selected sensor window 
11. Set other parameters of the sensor MIN, MAX values Units etc. 
12. Write configuration to module 
13. Open RT Testing&Monitooring Window > Hardware. Press [Start monitoring] button 
14. Go to RT Testing&Monitooring Window > Event Monitoring TAB. Software will show 
real time sensor values, and alarm states 
15. If you need to receive SMS with sensors alarm, go to GSM communication> SMS/ 
DIAL Reporting window   
16. Enter telephone numbers of users and mark alarm events that you want to receive. 
Open "Reporting SMS&DIAL" window. Set user phone number, and choose reporting 
option Sensor1 - Sensor32 Alarm/Restore.   Module will send SMS to user  in case of 
sensor alarm event 
17. Write configuration 

 

 

 
Do not reverse the polarity 
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4.1.1 Humidity sensor watchdog 

 

The sensor restarts when the system recognizes sensors not being processed for some 
time. If the sensor will not communicate with the module more than the programmed time 
(for example 2min), the system will reset the sensor. It is the way to ensure the stable 
work of the system, because the sensor will be reset if needed. For this purpose any of 
OUT1-OUT4 can be used. 
 

 

The output should be configures as sensor reset: 
Go to “Outputs” window. 
Set “Out definition” to “RH Sensor trouble”, “Mode” – “Steady”.  
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4.2 Steps to start analog sensors, connected to the inputs 0-10V, 0-20mA, 4-20mA  
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Figure 19 PT100 connection  

Step by step to start analog sensors: 
 
1. Connect analog voltage sensors to In1, In2, In3 and connect analog current sensors to I/O1, 
I/O2 according connection diagram. 
2. Security system sensors, could be used in the system, if required. 
3. If security system sensors is not in use, the inputs should be disabled in “Zones” window. 
4. Analog sensors should be calibrated in the Automation/Sensors window. Double click on the 
selected sensor’s line.   Analog sensors could be selected from the default list. Units could be 
changed. Sensors calibration is possible by changing multiplier, offset. 
5. When all changes has been done, the configuration should be written, by pressing “Write” icon. 
6. Open RT Testing&Monitooring Window > Hardware. Press [Start monitoring] button 
7.Go to RT Testing&Monitooring Window > Event Monitoring TAB. Software will show real time 
sensor values, and alarm states 
8. If you need to receive SMS with sensors alarm, go to GSM communication > SMS/ DIAL 
Reporting window. Enter telephone numbers of users and mark alarm events that you want to 
receive. Open "Reporting SMS&DIAL" window. Set user phone number, and choose reporting 
option Alarm/Restore.   Module will send SMS to user  then sensor alarm event occurs 
9.Write configuration 
 
There is the possibility to convert Celsius to Fahrenheit or vice versa, or calibrate the sensors 
measuring. 
Two point is the simplest as the equation is y=mx+c. It is the equation of a straight line, the graph 
of a linear sensor. Y is the output value, m is the multiplier otherwise known as the slope or 
gradient and c is the offset. X is the input value. 
Go to “Automation/ Sensors” window and double click on the selected sensor’s line. 

 
Figure 20Sensor calibration area 
 

 
Figure 214-20mA sensor connection with 

12V system 

 
Figure 224-20mA sensor connection 

with 24V system 
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4.3 Steps to start temperature sensors DS18b20. 

 

 
Do not reverce the polarity 

 

 

The DS18b20 digital thermometer provides 12-bit Celsius temperature measurements. The DS18b20 communicates over 

a 1-Wire Each DS18b20 has a unique 64-bit serial code, which allows multiple DS18b20s to function on the same 1-Wire 

bus. Thus, it is simple to use one to control many DS18b20s distributed over a large area. Applications that can benefit 

from this feature include HVAC environmental controls, temperature monitoring systems inside buildings, equipment, or 

machinery, and process monitoring and control systems. 

Applications/Uses 
 

 Consumer Products 

 Industrial Systems 

 Thermally Sensitive Systems 

 Thermometers 

 Thermostatic Controls 
 

Key Features 

 Measures Temperatures from -55°C to +125°C (-67°F to +257°F) 

 ±0.5°C Accuracy from -10°C to +85°C 

 Each Device Has a Unique 64-Bit  
 

 

  

 

 

 

 

 

     
 

1. Connect 1-Wire sensors DS18b20 to D1, D2, D3 according connection diagram.  

 

Figure 24DS18b20 connection  with long distance UTP or FTP cable 

 
2. If you need to connect more sensors to the same input, connect them as a star.  In order to compensate line impedances, each line should be 

separated by 82-120 Ohm resistors. 

 

 

The resistor must be as close as possible to the contacts of the module GTalarm2.  

 

 

Figure 23DS18b20 sensor 
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Figure 25Star connection 
 

3. Sensor’s type should be select in the System Options> Digital I/O Settings window. Set digital input definition D1, D2, D3 to Dallas 1-Wire Bus 
option. 

4. Write configuration by pressing write icon. 
5. Power module. 
6. After module starts , read configuration 
7. Go to “Automation/ Sensors” window  in the SERA2 software 
8. Double click on the selected sensor’s line.  
9. Click on “Sensor type/ hardware location” and default sensor settings appear. In sensors table column Sensor HW ID find registered sensors 

DS18b20 looks like "GTalarm2, Input D1, 1-Wire, DS18B20 Temperature, SN:28AE51560500" Location of the sensor can be changed choosing 
wanted sensor in the list.  

10. Double click on the sensor row opens selected sensor window. Set other parameters of the sensor MIN, MAX values Units etc. 
11. Write configuration to module 
12. Open RT Testing&Monitooring Window > Hardware. Press [Start monitoring] button 
13. Go to RT Testing&Monitooring Window > Event Monitoring TAB. Software will show real time sensor values, and alarm states 
14. If you need to receive SMS with sensors alarm, go to GSM Communications > SMS DIAL Reporting window. Enter telephone numbers of users 

and 
15. Mark alarm events that you want to receive. Open "Reporting SMS&DIAL" window. Set user phone number, and choose reporting option Sensor1 

- Sensor32 Alarm/Restore.   Module will send SMS to user  then sensor alarm event occurs 
16. Write configuration 

 

How to identify sensors, connected to the inputs? 

Sensors could be connected one by one and write the serial number and the name of the sensor.  Each sensor has a name, it is entered in SERA2 in the 

“Automation / Sensors” window. 

If all sensors connect at the same time, they will be registered in random way. If the sensors are connected to the star and if you want to know where the 

sensor is, then you can raise the temperature of the one sensor and see where the sensor is located. Let's say, the temperature of all sensors is 10 

degrees, the temperature of one sensor is raised to 20. Look to the Sera2> RT Testing&Monitoring“> Sensors/Automation window and you will see to 

which input the sensor is attached 

1-Wire Network Topologies 

1-Wire networks are often quite "free form" in structure, they usually fit into a few generalized categories, based on the distribution of the 1-Wire slaves 

and the organization of the interconnecting wires. 

- Linear topology. The 1-Wire bus is a single pair, starting from the master and extending to the farthest slave device. Other slaves are attached 
to the 1-Wire bus with insignificant (< 3m) branches or "stubs." 

- Stubbed topology. The 1-Wire bus is a single main line, starting at the master and extending to the farthest slave. Other slaves are attached to 
the main line through branches or stubs 3m or more in length. 

- Star topology: The 1-Wire bus is split at or near the master end and extends in multiple branches of varying lengths. There are slave devices 
along, or at the ends of, the branches. 

Linear topology. Stubbed topology. Star topology: 

GTalarm2 module

Sensors DS18b20

1 2 3 4 5

 
Figure 26 Wiring linear topology 

GTalarm2 module

Sensors DS18b20
5

1 2 3 4

>3m stubs

 
Figure 27 Wiring stubbed topology 

45
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2

1GTalarm2 module

Sensors DS18b20

 
Figure 28 Wiring star topology 

 

When different topologies are intermixed, it becomes much more difficult to determine the effective limitations for the network. As a rule, the designer 

should apply the most conservative of the criteria in these cases. 

Using cat 5 cable is best and will make it easier to maintain a working 1-wire network when you expand and add more sensors. The data and ground 

should use one twisted pair, for example blue/blue-white. A single wire from another pair is used for the 3.3 volt supply. 
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Don't double up wires on the assumption that this lowers resistance and is a 'good thing', it actually alters the impedance of the network and makes it less 

reliable. All unused wires in the cat 5 cable should be left unconnected (don't connect them to ground).When running a 1-Wire bus, Dallas recommend that 

you use an unshielded Cat5 cable for the bus. Do not use shielded cable as the capacitance increase will upset the network. 

If you intend to have a large 1-Wire network, it is important that you design the network correctly, otherwise you will have problems with timing/reflection 

issues and loss of data. You must connect each sensor to a single continuous cable which loops from sensor to sensor in turn (daisy chain). This will 

reduce potential miss-reads due to reflections in the cable. Each sensor should have a maximum of 50mm (2") of cable connected off this main network.  

Even when using this method, connecting more than 10-15 sensors will still cause problems due to loading of the data bus. To minimize this effect, place 

a 100-120Ω resistor in series in the data line of each sensor before connecting to the network. The total length of the bus from 10 to 100m. Depending of 

cable quality sensors number on bus, and environment noise. There is possibility to connect up to 32 devices. 
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Figure 29DS18b20 sensors connecting to the module GTalarm2 when different topologies are intermixed 

If 1 or 2 temperature sensors connected to 
the module GTalarm2 resistors are not 
required. However, if the sensors are 
combined with different topologies, 
separation of 82-120Ohm resistors is 
required. Different topologies must be 
separated through 82-120Ohm resistors. 
The resistors must be connected as close as 
possible to the contacts of the module 
GTalarm2. 
If the sensors do not work properly, noise is 
generated, we recommend connect 470-
2000uF capacitors as showed in the figure 
below.  
The capacitor is connected at the end of the 
line as close as possible to the sensor. 
 
 

Sensor 

DS18b20

470-2000 uF

d
a
ta

- +

 
Figure 30 Capacitors connecting to the 
sensors 

 

Begin the installation by mounting additional devices in the cabinet using the stand-offs provided, then mount the cabinet in a dry, protected area with 

access to unstitched AC power. Install hardware in the sequence indicated in the following pages. Do NOT apply power until installation is complete. 

 

 

  Minimum ¼” (6.4mm) separation must be maintained at all points between power limited and non-power limited wiring and connections. 

5 How to identify sensors, connected to the inputs? 

1. You can connect sensors one by one and write the serial number and the name of the sensor.  Each sensor has a name, it is entered in 

SERA2 in the “Automation / Sensors” window. 

2. If you connect all sensors at the same time, they will be registered in random way. If the sensors are connected to the star and if you want to 

know where the sensor is, then you can raise the temperature of the one sensor and see where the sensor is located. Let's say, the temperature 

of all sensors is 10 degrees, the temperature of one sensor is raised to 20. Look to the monitoring window and you will see where the sensor is. 
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Figure 31Sera2> RT Testing & Monitoring > Sensors/ Automation 

 

 
Figure 32Sera Cloud Android App 

6 Low and high alarm threshold settings. Output activation. 

 

 
Sera2> Automation/ Sensors. (Double click on the line) 
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If Digital inputs D1, D2, D3 are used, then  
1. go to System Options> Digital I/O Settings and select required parameters 
2. Press “Write” in the command line. 
3. Power the module 
4. Press “Read” in the command line 
5. Go to Automation/ Sensors window 
6. Select the sensor 
7. Set High/ Max Value Action Settings 
8. Set Low/Min Value Action Settings. 

 
More information: 
4.1 Steps to start humidity sensors DHT22/AM2305/AM2306/AM2320/AM2321  
4.3 Steps to start temperature sensors DS18b20. 
 

If In1…In4 or I/O1…I/O2 inputs are used then 
1. Go straight to the Automation/ Sensors window. 
2. Select the sensor 
3. Set High/ Max Value Action Settings 
4. Set Low/Min Value Action Settings. 

 
More information: 
4.2 Steps to start analog sensors, connected to the 
inputs 0-10V, 0-20mA, 4-20mA 
 

 
 

 
Temperature 28 degrees (Max Value To Activate Output) 
OUT1 (Output) will be activated after 
1000ms (Max Value Output Control Delay) 
Temperature 30 degrees (Max Value Alarm Event/ SMS)– alarm SMS 
With the text “Max Value” (Alarm Event SMS Text) 
Will be send after 10000ms (Max Alarm Event Delay) 
 
Max Value Hysteresis=1 
When temperature rise to 28 degrees, turn on the cooler 
When temperature drops to 27 (28-1) degrees, the system will turn off the cooler. 
 
 
 
 
 

 
 
5. When all changes has been done, the configuration should be written, by pressing write icon. 
6. Open RT Testing&Monitooring Window > Hardware. Press [Start monitoring] button 
7.Go to RT Testing&Monitooring Window > Event Monitoring TAB. Software will show real time sensor values, and alarm states 
8. If you need to receive SMS with sensors alarm, go to GSM communication > SMS/ DIAL Reporting window. Enter telephone numbers of users and 
mark alarm events that you want to receive. Open "Reporting SMS&DIAL" window. Set user phone number, and choose reporting option Alarm/Restore.   
Module will send SMS to user  then sensor alarm event occurs 
9.Write configuration 
 

7 Every field explanation in Sera2> Automation/ Sensors window 

 
Double click on the selected sensor’s line will show selected sensor’s configuration window.  

2 3 4 28 6 16 7 17 8 18 14 24 13 23 11 21 25

 

Figure 33 the example of Automation/Sensors (Automation/Sensors/Analog Inputs) window 
  

For example double click on “Sensor Name 1” line will show “Sensor 1 Settings” window.  The required parameters of the sensor 1 can be set in that 

window. 



GTalarm2 Application Note: Automation   22 | E N    

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

 

Figure 34 the example of Automation/Sensors (Automation/Sensors/Analog Inputs) window 
 

Table 3 Explanation of every field in "Automation/ Sensors" window 

2 Sensor Name Sensor name 

3 
Sensor Type/  
Hardware location= Sensor Hardware ID 

Select the sensor type hardware location 
Location of sensor connected to the module. Select connected sensors 

Sensor disabled  

GTalarm, Input IN1…IN4, 0-10V Voltage input IN1… IN4, 0-10V assigned 

GTalarm, Input I/O1…I/O2, 0-10V Voltage input. I/O1…I/O2 0-10V assigned 

GTalarm, Input I/O1…I/O2, 0-20mA Current I/O1…I/O2 , 0-20mA assigned 

GTalarm, Input D1…D3, 1-Wire 
DHT22 RH, Humidity 

Digital input D1…D3, 1-Wire DHT22 RH, 
Humidity assigned 

GTalarm, Input D1…D3, 1-Wire 
DHT22 RH, Temperature 

Digital input D1…D3, 1-Wire DHT22 RH, 
Temperature assigned 

1-Wire Temperature sensors Digital input D1…D3, 1-Wire DS18b20 
Temperature sensor 

 

4 Sensor Unit Text= Unit Sensor Unit Text 

6 Max Value Alarm Event/ SMS= Max Val SMS Maximum allowable temperature value, which will be reported. 

7 Max Value To Activate Output= Max Val OUT Maximum allowable temperature value, which will activate the selected output 

8 Max Value Hysteresis= Max Hyst Temperature hysteresis value is indicated. 

9 Max Alarm Event Delay= Max SMS Delay …………… 

10 
Max Value output Control Delay= Max OUT 
Delay 

…………… 

11 Output= Max OUT 
The output which will be activated, when the maximum allowable temperature value will 
be reached 

12             Contact ID Report Code= Max CID Report Contact ID code 

13 Alarm Event SMS Text= Max Alarm SMS 
Text, which will be visible in SMS message in case of set temperature excess, is 
entered. 

14 Enable Alarm Event/ SMS= Max SMS en  The indicated report will be sent when it is checked. 

16 Min Value Alarm Event/ SMS= Min Val SMS Minimum allowable temperature value, which will be reported. 

17 Min Value To Activate Output= Min Val OUT Minimum allowable temperature value, which will activate the selected output. 

18 Min Value Hysteresis= Min Hyst Temperature hysteresis value is indicated. 

19 Min Alarm Event Delay= Min SMS Delay …………… 

20 
Min Value Output Control Delay= Min OUT 
Delay 

…………… 

21 Output= Min OUT 
The output which will be activated, when the minimum allowable temperature value will 
be reached 
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22 Contact ID Report Code= Min CID Report Contact ID code 

23 Alarm Event  SMS Text= Min Alarm SMS 
Text, which will be visible in SMS message in case of set temperature excess, is 
entered. 

24 Enable Alarm Event/ SMS= Min SMS en The indicated report will be sent when it is checked. 

25 X-multiplier= Mult Coef Correction 
X-multiplier coefficient. Following the equation “Temperature=X*ADC+Y“to calculate X 
and Y coefficients. Measure temperature in two points at least.  

26 Y-offset= Sum Coef Correction 
Y-offset coefficient. Following the equation “Temperature=X*ADC+Y“to calculate X and 
Y coefficients. Measure temperature in two points at least. 

 Temperature= X*ADC+Y  

12 Contact ID Report Code= Max CID Max and Min Contact ID report codes. Report codes are the Ademco CID, SIA DC09 
format. The module can automatically program a set of default report codes. The 
Contact ID Reporting Format can be modified and changed. Enter any of the desired 
text in the “Alarm SMS Text” field. 

22 Contact ID Report Code=  Min CID 

/28 RT Value 
After the connection to the module and after clicking on a read icon the real time value 
of the sensor will be displayed in this field. 

Fig  ilustrate how to calculate X-multiplier and Y-offset with excell chart. 

 

8 How to calibrate the sensor 

Following the equation Temperature=X*ADC+Y, selecting X and Y coefficients.  

1. Go to Sera2 software, Automation/ Sensors window, double clicked on the selected sensors line.  
2. Measure temperature at least in two points with the accurate thermometer.  
3. Read temperature ADC indications at these points in the “RT Testing & Monitoring” > “Sensors/ Automation” window. 
4. Following the equation “Temperature=X*ADC+Y“to calculate X and Y coefficients. Calculated X and Y coefficients should be programmed in the 

module. It is easy to calculate X and Y coefficients in MC Excel by using trend line. 
 

 
Figure 35ilustrate how to calculate X-multiplier and Y-offset with excell chart. 

 
Figure 36 Sensor Calibration area in 
Sera2> Automation/ Sensors (double click 
on the sensor’s line) 

 

9 How to convert Celsius to Kelvin or Celsius to Fahrenheit 

Sensor Calibration area in Sera2> Automation/ Sensors (double click on the sensor’s line) 
1. Go to Sera2> Automation / Sensors 

(double click on the sensor’s line).  
2. Enter Y (offset) and X (multiplier) values. 
3. Change the units to Kelvin or Fahrenheit 

in the  Sera2> Automation/ Sensors 
(double click on the sensor’s line).  

 

Celsius to Fahrenheit conversion  

Y(offset)=32, X(multiplier)=1.8 

Celsius to Kelvin conversion  

Y(offset)=273.15, X(multiplier)=1 

Table 4Figure 27 Sensor Calibration area in 
Sera2> Automation/ Sensors (double click on 
the sensor’s line) 
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10 Outputs.   

 

 
Sera2> Outputs (PGM) 

GTalarm2 comes equipped with four open-collector PGM outputs allowing to connect up to four devices or relays. Also GTalarm2 comes with two 

programmable 20mA outputs, three 10 mA and max voltage 3.3V outputs, and with one 20mA programmable output BUS. 

If the output is not in used, it should be disabled. Once a PGM output is disabled, it can no longer be turned ON or OFF unless it is enabled again. 

It is possible to instantly turn ON an individual PGM output for a determined time period and automatically turn it OFF when the time period expires. When 

the PGM output is turned ON or OFF, the system will send a confirmation by SMS text message to the user phone number 

The automatic action of the determined PGM output can be set as 
follows:  

- Turn ON – Determines whether the PGM output is to be turned 
ON.  

- Turn OFF – Determines whether the PGM output is to be turned 
OFF.  

- Pulse – Determines whether the PGM output is to be turned ON 
or OFF for a set period of time in seconds based on the PGM 
output startup state set up.  

The PGM output can be automatically activated under the following 
events:  

- System armed or disarmed 
- Alarm begins or stops 
- Zone violated, or restored.  

The user can also set a custom text, which will be sent by SMS text 
message to user phone number when the automatic PGM output action 
is carried out. 

 

 
Fig. 1 Relay connection to OUT1-OUT4, 
I/O1, I/O2 20mA 

1. Install SERA2 software.  
2. Connect the module to the computer via mini USB cable. 
3. Go to Outputs (PGM) window in the SERA2 software 
4. Parameters of the selected output should be set:  
5. output operation description (OUT definition): disable, bell, buzzer, flash, system state, ready, 

automation/ CTRL, AC OK, battery OK, ARM/ DISARM, alarm indication, lost primary channel, lost 
secondary channel, fire sensor, RH sensor trouble. 

6. State type: flash, timer, steady mode. 
7. If necessary output operation might be inverted. 
8. Write configuration by pressing write icon 

 

 
Outputs can be controlled only in Automation/ CTRL mode. 
 

9. If you need to control outputs by short call or SMS, go to “Users & Remote Control” window and enter 
telephone numbers of users, who will be able to control selected outputs via free short call.  

10. Write configuration by pressing write icon 
 
For sound and visual signaling, please refer to Fire and Security application note. 
 

 

 

 In order to control big power alternating current equipment, it is comfortable to use solid state relays.  

 Standard AC/DC adapter with the voltage 10V-14V and current >=1A might be used to powering the module. 
 

 

 

 

Figure 37 The example of Outputs window 
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Table 5 Explanation of every field in "Outputs" window 

1 ID Output sequence number. 

2 
Output Location 
in Hardware 

The outputs hardware location. 

3 Output Label Output name 

4 Out definition 

Selection of output operation mode. 

21  Disable Output disabled 

27  Remote Control 
Remote control by call mode is enabled. Output designed for connection of 
electrical devices which will be controlled by SMS message or phone call 

35  RH Sensor Trouble 
Output for RH Sensor trouble operation. In this mode output can automatically 
reset Humidity sensor if trouble occurs. 

 

5 Mode 

Output control mode. 

36  Steady Steady ON/OFF mode 

37  Timer Output ON pulse mode 
 

6 Out Timer Pulse time duration can be from 1 to 999999 sec. 

7 Invert Inversion is activated 

8 Pulsating Pulsating mode is activated. Then output is activated it will pulsate according pulse ON/OFF time. 

9 Pulse ON Time Pulsating mode pulse ON duration.  

10 Pulse OFF Time Pulsating mode pulse OFF duration.  

 

 
Outputs can be set as timers. 
 
 
1. When output is activated for “Out Timer” time 

interval, 
2. Relay contact start changing state from ON (pulse 

time ON) to OFF (Pulse time Off) 
3. This cycle will repeat until output is deactivated. Output signal

Pulse time ON

Pulse time OFF

Pulse time ON

Pulse time OFF

Output state

Output ON

Output OFF

 

 

11 Power loss alarms. 

If power loss, or other troubles should generate alarm to the users, please refer to the Fire and Security application note 

12 Alarm events such as open doors 

If operational events such as door opening may also need to be logged and recorded, please look to the fire and security system’s application note. This 

information is useful because operational events (for example door opening in freezer rooms and cold rooms) can have a significant impact on 

environmental control. 

13 Remote monitoring, control, configuring, FW updating over the internet 

If remote monitoring, control, configuring, FW updating over the internet is needed please refer to the “Remote monitoring via Linux Server” application 

note. 

14 General system configuration 

 

 
Sera2> System Options> General System Options 

The system comes equipped with internal real-time clock (RTC) with battery that keeps track of the current date and time. Once the system is up and 
running, the user must set the correct date and time, otherwise the system will not operate properly.  SERA2 software provides the ability to select the 
Time Zone and The user may also choose Set module time from PC, which instantly provides the exact PC time.  When the system is connected to the 
monitoring station via IP connection the date and time will be automatically synchronized with the monitoring station. 

 

 

If the module has been connected first time to the power supply, or power supply has been disconnected for a long time, the time of the 
module should be set again. 

 

The module can send a trouble report and restrict arming if some of selected troubles [Restrict ARM] exist during close event. 
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Figure 38 the example of System Options > General system Options window. 
 

Table 6 Explanation of every field in "General System Options" window 

1 Object Name  

2 SIM Card PIN  SIM card PIN code. Default 1234 

3 Installer Password  
The default installer password is 000000. This password allows you to enter programming mode, where you can 
program all features, options, and commands of the module.  

4 SMS User Password  
The default SMS User Password is 123456. This code allows you to utilize arming method, as well as program 
user codes.  

5 
User Access Code 
Format 

A 4-digit or 6-digit user access code format can be selected. 

6 I/O1 Settings 
2-Wire Smoke detector (Fire current loop) or 0-10V Analog Input (Zone or Sensor) or Output or – 0-20mA, 4-
20mA Current Loop Sensor could be assigned to the I/O1 

7 I/O2 Settings 
2-Wire Smoke detector (Fire current loop) or 0-10V Analog Input (Zone or Sensor) or Output or – 0-20mA, 4-
20mA Current Loop Sensor could be assigned to the I/O2 

15 
0-10V Analog Input 
(Zone or Sensor) 

0-10V Analog sensors will be connected to the input 

16 Output Input will be used as output 

17 
2-Wire Smoke Detector 
(Fire current loop) 

2-Wire Smoke detectors will be connected t the input. 

18 
0-10mA, 4-20mA Current 
Loop Sensor 

0-20mA, 4-20mA Current Loop Sensors will be connected to the input. 

8 
Clear Event Buffer After 
Reset  

When the cell is checked, the memory of unsent reports will be deleted after the module resetting 

26 Set module time from PC To set the clock click Set time from PC button and the clock will be set using computer’s clock.  

27 Read module time  To read the clock of panel. 

28 PC Time  

29 Panel Time  

14 Reset Device Reset module command 
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15 Logging events 

 

 
Sera2> Events Log 

  

The Event Log window show real time information of the events that has been occurred. Every enabled new event is stored in log. Internal event log has 
some limitations.  It is possible to store 2048 events in the events log buffer. Events could be saved to the file.  If you need to store more events, you can 
use Sera cloud server. The user is able to see every event remotely via web app. 

The event log allows to chronologically register up to 2048 time stamped records regarding the following system events:  

 System start.  

 System arming/disarming.  

 Zone violated/restored.  

 Temperature deviation by MIN and MAX boundaries.  

 Configuration via USB.  

 

Figure 39 How to find required Events Log window. 
 

 

Figure 40 the example of the Events Log window. 
 

Table 5 explains every field in the Events Log window. 

Table 7 Explanation of every field in "Events Log" window 

1 Read Event Log Events could be read from the module by clicking Read Event Log button 

2 Clear Event Log Events could be cleared from the module by clicking Clear Event Log button 

3 Event Number Event sequence number 

4 Event Object number and registered event report in Contact ID code. 

5 Time Event date and time. 

6 Note Event report text which was indicated. 

15.1 Event monitoring  

 

 
Sera2> RT Testing & Monitoring> Event Monitoring 

  
The following information is displayed: 

 
Figure 41 The example of RT Testing & Monitoring > Event Monitoring window 

Table 8 Explanation of every field in "Event Monitoring" window 

3 … Event number 

4 CID Contact ID Code 

5 Time Event date and time 

6 Note Event report text which was indicated. 
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15.2 Monitoring Inputs, outputs & general system info 

 

 
Sera2> RT Testing & Monitoring> Hardware 

  
RT „Testing & Monitoring” window „Hardware“ tab enables you to view and test the current status of each input, output  
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Figure 42 The example of RT Testing & Monitoring > Hardware window 
 

Table 9 Explanation of every field in "Hardware" window 

1 Start Monitoring Pressing Start Monitoring button starts the monitoring of the module. 

2 Stop Monitoring Pressing Stop Monitoring button stops the monitoring of the module. 

3 IMEI IMEI number of GSM modem available in the module 

4 SIM ICCID 
ICCID (Integrated Circuit Card Identifier) - A SIM card contains its unique serial number (ICCID). 
ICCIDs are stored in the SIM cards and are also printed on the SIM card. 

5 SIM Card 
If note READY is visible, it means that SIM card is fully functioning. Otherwise, check whether PIN 
code request is off or replace SIM card. 

6 Signal level Signal strength of GSM communication 

7 Registration State of GSM modem registration to GSM network. 

8 
SMS Service Centre 
Address 

SMS center number. This number should be checked if it is correct. If this number is incorrect. SMS 
messaging may be impossible. This number may be changed after inserting SIM card into any mobile 
phone. 

9 System Voltage 
Power supply voltage. Nearby number is value of ADC voltage. When multiplying this number by the 
coefficient Fig. 32, voltage value (V) will be achieved. 

10 System Voltage System voltage OK/Trouble 

11 RTC Clock Real time clock OK/Trouble 

12 Module Real Time Clock Indicates the time of the module RTC 

13 Set RTC Clock By pressing this button real time clock of the module will be set. 

14-17    Inputs In1…In4 In1…In4 is the indicated input ADC and voltage value V. 

18-19 I/O1…I/O2 I/O1…I/O2 is the indicated voltage ADC value and current ADC value mA. 

20-22 D1…D3 (I/O) Check box nearby the digital inputs D1…D3 (I/O) means that the input has ‘0’ or ‘1’ state. 

23 BUS (I/O) Check box nearby the programmable output BUS (I/O) means that the input has ‘0’ or ‘1’ state. 

24-27 Out1…Out4 On/Off 
Checked box nearby the appropriate output Out1…Out4  means that this output currently has ‘0’ or ‘1’ 
state. The output could be activated by pressing On/Off button 

28-29 I/O1…I/O2 On/Off 
Checked box nearby the appropriate input/output I/O1…I/O2 means that this input/output currently has 
‘0’ or ‘1’ state. The output could be activated by pressing On/Off button 

30-32 D1…D3 (I/O) On/Off 
Checked check box nearby the digital outputs D1…D3 (I/O) means that the output currently has ‘0’ or 
‘1’ state. 

33 BUS (I/O) On/Off Checked check box BUS (I/O) means that the output currently has ‘0’ or ‘1’ state. 

 

  



GTalarm2 Application Note: Automation   29 | E N    

 

15.3 Realtime Testing & Monitoring > Sensors/ Automation 

 

 
Sera2> RT Testing & Monitoring> Sensors/ Automation 

1

2 3 4 5
 

Figure 43 the example of RT Testing & Monitoring > Sensors/ Automation window 
 
Table 10 Explanation of every field in "Sensors/ Automation" window 

1 Sensor1…Sensor32 Sensor number 

2 Value The value of sensor’s voltage 

3 Active If checked and the color is green, the sensor is active 

4 High Val Alarm If checked and the color is red, the high value alarm is generated 

5 Low Val Alarm If checked and the color is red, the low value alarm is generated 

 

 

 


